BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
HomeHome  RegisterRegister  Log in  
Log in
Log in automatically: 
:: I forgot my password
Who is online?
In total there are 2 users online :: 0 Registered, 0 Hidden and 2 Guests


Most users ever online was 132 on Wed Oct 04, 2017 3:26 pm
Latest topics
» Transmission temp sensor help..
Sun Mar 11, 2018 2:41 pm by Ironfistdog

» WTB: 235/70/R15 tires
Mon Jan 15, 2018 8:42 pm by demilo

» Triumph C 7000 Lift
Mon Jan 08, 2018 1:56 am by demilo

» The SSheriff (1996 9C1)
Fri Jan 05, 2018 2:05 am by MASShole9C1

» WTB: caprice taillights
Wed Jan 03, 2018 2:51 am by demilo

» New Ride, New Forum!
Tue Jan 02, 2018 2:47 am by demilo

» 1980 coupe DeVille for sale
Fri Dec 29, 2017 7:01 pm by IMPALADAKID

» The Official 1987 Two Door Body Off RE-build Thread!
Thu Dec 28, 2017 1:25 am by demilo

» 1980 Coupe De Ville
Wed Dec 27, 2017 3:07 am by demilo


Display results as :
Rechercher Advanced Search
March 2018

Share | 

 94 caprice won't stay running

Go down 

Posts : 2
Join date : 2012-04-30

PostSubject: 94 caprice won't stay running   Mon Apr 30, 2012 1:51 am

My 94 caprice runs for a good 10 min then dies on me, seems like when the car is warmed. It usually takes about an hour for the car to start back up, seems like when the car is cooled.When trying to crank it I didnt see any spark from spark wires. I got new spark plugs w/o the wires, replaced the ignition coil, the ignition control module, and now the map sensor. So where am I, is it the distributor, any other sensors? oh yeah its a 94 caprice with lt1
Back to top Go down


Posts : 4287
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: 94 caprice won't stay running   Mon Apr 30, 2012 6:15 am

When it's running are you driving it? or just idling?

Are you saying only when it's warmed you lose spark?

That doesnt sound right but you need to clarify what your say

Did you see spark (by whatever method your using) when its cold & starts?

I had the sensor in the waterpump (ECT?) go & it would run cold & misfire & stumble BAD when warmed.

Never had to replace a MAP....maybe you should diagnos more before throwing parts.

BUT....against that statement....a ECT sensor is cheap


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Matt. Cool
Whine..eee...Silver LS6
Back to top Go down

Posts : 2
Join date : 2012-04-30

PostSubject: Re: 94 caprice won't stay running   Mon Apr 30, 2012 5:04 pm

I can be either driving or have it parked running, and its always Bout 10 minutes it will die. The guy who works for good year tires in my apartment complex told me to unplug one of my spark plug wires to see if I get a spark when trying to start the car, and when trying to crank the car up we didn't see any sparks. All the parts that I replaced so far is the map sesor, ignition coil and the ignition control module. Is it the distributor?
Back to top Go down


Posts : 2132
Join date : 2011-01-11
Age : 36
Location : Warren, MA

PostSubject: Re: 94 caprice won't stay running   Mon Apr 30, 2012 5:49 pm

Sounds like it's dying once it reaches closed loop. Did you try the MAF?
Back to top Go down
Sponsored content

PostSubject: Re: 94 caprice won't stay running   

Back to top Go down
94 caprice won't stay running
Back to top 
Page 1 of 1
 Similar topics
» 94 caprice won't stay running
» surestart wont stay running!
» New tubes, ST-70 transformers running hot
» Running Lean
» Roadmaster and Caprice Wagon doors

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: