BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log inLog in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there are 3 users online :: 0 Registered, 0 Hidden and 3 Guests :: 1 Bot

None

Most users ever online was 101 on Fri Nov 27, 2015 1:40 pm
Latest topics
» 2012 and up Caprice PPV
Sat Dec 03, 2016 4:36 pm by No Moa

» I wasn't even looking for this one, I swear!
Thu Dec 01, 2016 9:52 am by 95brmw

» This forum needs a pulse check.... pics included
Tue Nov 29, 2016 1:04 pm by Grumpy

» 1994 Roadmaster Estate Wagon
Tue Nov 29, 2016 10:15 am by lvd2340

» Who're You callin a Turkey?
Thu Nov 24, 2016 1:32 pm by 802

» New Ride
Thu Nov 17, 2016 8:17 am by silverfox103

» Complete SS interior.
Thu Oct 27, 2016 1:35 pm by No Moa

» 2016 9th Annual Roundup, List of Attendees
Tue Oct 18, 2016 1:04 am by MASShole9C1

» Pictures from the 2016 Roundup
Mon Oct 17, 2016 8:03 pm by toomanytoyz

Search
 
 

Display results as :
 
Rechercher Advanced Search
December 2016
MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
262728293031 
CalendarCalendar

Share | 
 

 Anyone recognize this?

View previous topic View next topic Go down 
AuthorMessage
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Anyone recognize this?   Sat Aug 08, 2009 8:56 pm

So my 95 ss (neglected but dd) within 2 days went from trouble to total risk
1 night I went to take it out & it hard started, stumbled missed....I shut it off & restarted. It started fine stumbled a little on slow take off & fought thru it all was fine.
I drive the 96 for a couple days then go to jump in the 95. It cranks but no fire. I dont give up cause it always runs. Had to hit the floor with the pedal to get it to fight thru & fire. Once it starts its fine other then a stumble just as I hit the gas. It isnt trustworthy right now. So I start easy, plugs & wires. No change. Whats next?.
How do you know if an OPTI is good? is a cap & rotor all that goes or is it the opti eye...or whatever? Saw Bill M's opti sticky & I can do that, but all I have for spare parts is a cap & rotor....EXPERT ADVISE NEEDED

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: Anyone recognize this?   Sat Aug 08, 2009 9:00 pm

Sounds like maybe a fuel pump going south. Mine had issues like you describe before the pump started to intemittently cut out completely.
Back to top Go down
QwikImpSS



Posts : 164
Join date : 2009-02-16
Age : 32
Location : Pembroke, NH

PostSubject: Re: Anyone recognize this?   Sat Aug 08, 2009 9:09 pm

I would change the fuel filter. Sounds like classic clogged filter symptoms.
Back to top Go down
Fishah



Posts : 1118
Join date : 2009-01-20
Age : 29
Location : Chicago, IL

PostSubject: Re: Anyone recognize this?   Sun Aug 09, 2009 3:10 pm

Yea it sounds Fuel related to me.
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Sun Aug 09, 2009 5:03 pm

I checked the fuel pressure & it was low (30-35) & jumped (dropped)as it stumbled
So you guys were right on the money.
Thought I'd try the filter even though I know its not that old & made the mistake of touching the rear brakeline right there behind the filter...DAMN went right thru it

(forgive the cell phone pic. You get the idea)
Glad it didnt happen on the road but it was ONLY the rears.
Fixed the line & put the filter in, put on the other RED caliper Matt painted seeing as he was helping me & didnt care about anything else..lol..I had to bleed anyway.
Tank needs to drop. Suggestions on pump?
BTW this was a world record for stock fuel pump.185K on original pump

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: Anyone recognize this?   Sun Aug 09, 2009 8:03 pm

Make sure along with the new pump you get a new strainer and make sure the pump includes a wiring harness. The harness will require you to cut and splice the 2 grounds together since our cars only have a single ground. Other than that the swap isn't any different from any other car.

My original pump lasted until around 175k miles
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 6:10 am

OK looks like the factory fuel pump was pretty good, I thought 185K was a record I guess its common.
So guys please let me know
Dropping the tank?....Easy....PIA.....Moderate?
I know I can get an AZ fuel pump, dont know about the harness but if I go this way I could do the job today
RMS will probably take 2 days
If someone knows of a better way PLEASE speak up now

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
Fishah



Posts : 1118
Join date : 2009-01-20
Age : 29
Location : Chicago, IL

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 10:07 am

I would not use an AZ pump.

I would get an ACDelco pump.

If you can get me the P/N for the pump I can get you an OEM one from Chevy at my cost... It'll be a little less than list. Probably a similar price to RMS.

You can use my lift to put it in also if you want.
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 10:23 am

Thanks, I'm trying to get P/N's now.
ISSF search being down really sucks, that was my source of info
I'll let you know, Thanks again

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
Guest
Guest



PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 10:30 am

White93ltz wrote:
I would not use an AZ pump.

I would get an ACDelco pump.
You can take that statement to the bank. AC Delco pumps good for many years, anything else and you might be replacing in 6 months. Ask me how I know this. Also get sock and ac delco wire harness for inside the tank.
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 10:50 am

Would I be stupid not to buy the sender assembly as well as the fuel pump & strainer
I dont want to go in again, but I dont have a clue if the sender is required too

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
Guest
Guest



PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 11:13 am

sdstick wrote:
Would I be stupid not to buy the sender assembly as well as the fuel pump & strainer
I dont want to go in again, but I dont have a clue if the sender is required too
A new sender is very expensive. If the lines coming off the sender are not rusted bad, just sand and paint to protect. If they are brittle from rust, then yes. Probably find a good used one here or the national forum
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 11:39 am

OK Bill thanks for the quick reply

Fisha, see below
-----------------------------------------
ACD FLS1072 - Fuel Tank Meter Sender
CASTING NUMBER: 25028954
Cross Reference for GM Part Number: 19179521
Supersedes: GM# 25028955
RMS wants $262.50
---------------------------------------------
ACD EP381 - High Output Electric Fuel Pump Kit
Does not include strainer
Cross Reference for GM Part number: 25163473
RMS wants $78.75
-----------------------------------------------
TS42 - Fuel Sender Strainer
Fuel Pump Filter/Strainer
Fits: 1994 - 1996 Impala SS
Cross Reference for GM Part Number: 25121832
RMS wants $14.75
------------------------------------------------
Looks like $356 before shipping
If you dont mind, see what you can do for pricing & delivery (delivery is most important) as I'm down.

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6


Last edited by sdstick on Mon Aug 10, 2009 8:30 pm; edited 1 time in total (Reason for editing : Cell dropped)
Back to top Go down
Fishah



Posts : 1118
Join date : 2009-01-20
Age : 29
Location : Chicago, IL

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 12:06 pm

I just called GM.

Their prices were NOT better than RMS by a long shot.

Sorry, but it definately won't be beneficial to go through me.
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 12:33 pm

REALLY appreciate you trying.
Also appreciate you offering up the lift, but this car isnt going far in its current state. The next start may never happen or it could die 5 feet after I make it start.
I'll be on my back in my driveway as soon as I get parts

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 12:38 pm

I went to PepBoys and got a Carter brand pump, since they have experience in fuel systems. The pump came with the wiring harness which was a bonus. The whole setup for pump, harness, and in-tank strainer was under $100 which isn't too bad considering it's name brand. I didn't bother with a new sending unit since they're expensive and mine works as well as any other GM has.

Pepboys Part #'s

Pump - P74037 - $74.99 - Carter - with wiring harness
Strainer - STS7 - $10.99 - Carter
Sending Unit - FG128B - Call For Pricing - SPI - doesn't include pump or strainer
Back to top Go down
iceman3201



Posts : 641
Join date : 2009-02-12
Age : 70
Location : south portland maine

PostSubject: anyone recognize this?   Mon Aug 10, 2009 4:50 pm

if i lived closer and had a little bit more money then i do now. id be there in a heart beat to help you. we older people have to stick together. Very Happy
Back to top Go down
http://iceman3201@maine.rr.com
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 6:15 pm

Thanks Brad & Ron
I'll have the parts tommorrow.
Probably tear into it in the afternoon
Hope I dont spoil this car up giving it new parts
My son Matt is breaking in slowly, he put on the center section of air dam while I fixed the rear brake line. Thanks to him the average age dropped to 32.

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 6:34 pm

Where are you located so people know if their local enough to help out.
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 9:56 pm

I'm in andover. I only ask for help when I NEED it.
No plastic tank or multi piece fuel pump/sender with a sock will stop me.
14 years of rust on every nut & bolt might stop me but nothin else

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: Anyone recognize this?   Mon Aug 10, 2009 11:29 pm

just remember to get the little fuel line disconnect tool since these lines release with a little clip mechanism instead of a threaded nut.
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Tue Aug 11, 2009 9:16 am

Now that you mention it, I bought the cheapy plastic assortment because I wasnt sure if 5/16 or 3/8 was needed.
Now I'm a mechanical engineer scratch , so usually I can figure out how most things work with a little time & effort,
but these efin things are ridiculous.
My only guess is they DONT work on the filter for that I just used needle nose but DO work on regular fuel lines where you can slide them up the line under the fitting.
Can someone confirm this? I hate my lack of experience in these matters.
And yes I will buy the REAL tool for next time

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: Anyone recognize this?   Tue Aug 11, 2009 1:00 pm

They wrap around the line and then slide up into the overlapping mechanism. Then just push in on the tool as you wiggle the mechanism and it will eventually pop apart. Sometimes you need to use the tool that is a size too big or small and it'll depress the clips better for some reason. Just don't get frustrated and make sure to take you time and eventually they will pop apart.

If you find you need a new filler hose while your there let me know Wink
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Tue Aug 11, 2009 1:06 pm

bammax wrote:
If you find you need a new filler hose while your there let me know Wink
Already had you in mind.
You know how that goes..Murphys Law.because you have it I wont need it

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
toomanytoyz
Club President


Posts : 6870
Join date : 2009-01-20
Age : 40
Location : East Hampstead, NH USA

PostSubject: Re: Anyone recognize this?   Tue Aug 11, 2009 5:15 pm

You may need a whole sending unit assembly if it's been driven in the winters up here. When the fuel pump went in Morticia at 204K, I dropped the tank to find all the metal fuel lines swolllen up to BIGGER than the connectors on the ends! But it was cheap through autozone. I had to replace the connectors on the plastic lines, too, and they had the repair kits in stock. I think it was like 140 bucks for the sending unit assembly and 60 bucks for the pump and 10 bucks for the strainer. They had the harness too, which you ABSOLUTELY want to replace, for like 10 bucks, but it was also included in the sending unit assembly.

Dropping the tank is easy if the straps and bolts aren't rusted. I had to replace my straps, too. But IIRC, it's just two 17mm bolts in front of the tank, up between the rear springs on that crosssmember there. Hopefully the tank is empty-ish. Mine was full. Ugh!

All in all, not a bad job though!

_________________
Bill "The Verb" Crovo - Resident Car Slut & Unicorn Hunter

A Toasted Marshmallow, A Long German, A Lame Suburban and expensive dreams...
Missing all my previous B's, D's and V... Sad
American Ricer
www.badassofne.net
"Ooooh! Look! Something shiny!"
NO MORE UNICORNS!!!!!

LOWER IT!!! Wink
Back to top Go down
http://impalass.uniquekind.net/
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Tue Aug 11, 2009 7:58 pm

So I have the parts & I take off early to work on the car.
Its about 200 degrees in the sun. I start the siphon to take 5 of the 7 gallons out of the tank.
Under the car I go looking, wirebrushing & pbblastin.
I removed the tank heat shields. Brush 3 pounds of rust out of my eyes & hookup the fuel pressure gauge cause I couldnt remember HOW low it was & it puts out like 15 psi. I turn the key the 2nd time it goes to 30 so I start it up. Like there never was a problem, right up to 40 & reasonably steady under rev.
So now its efin with me, trying to get me out on the road only to strand me at the worst possible time.
I repeat this 5 times & it shows no signs of problem.
I decided to crack all the bolts to make sure this is coming out & 2 things happen.
First the 2-15mm closest to the rearend break free but the strap basically de-skins (like there were 3 layers that turned to 1 still held fine though) & second the sideways 13mm bolts will spin but the nuts have changed to something between 12 & 13mm so theyre not worth the effort.
Up on top it looks reasonable but we'll see.
New plan...get set of mounting straps & some hardware for rear most, use a cutoff wheel on those & drop that thing outta there.
No idea how to use some of the parts that came with the pump but once I see the old one I'm sure it'll be fine.
Did find out that even using soft tubing can somehow mess up your sender.
Anyone have straps?

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: Anyone recognize this?   Tue Aug 11, 2009 9:21 pm

If you need a hand from someone that's done it before just ask. It's not that tricky though other than the wiring harness difference.
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Tue Aug 11, 2009 9:30 pm

bammax wrote:
If you need a hand from someone that's done it before just ask.
Thanks, appreciate the offer

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
toomanytoyz
Club President


Posts : 6870
Join date : 2009-01-20
Age : 40
Location : East Hampstead, NH USA

PostSubject: Re: Anyone recognize this?   Tue Aug 11, 2009 9:52 pm

bammax wrote:
If you need a hand from someone that's done it before just ask.

Why... you know someone? Wink

_________________
Bill "The Verb" Crovo - Resident Car Slut & Unicorn Hunter

A Toasted Marshmallow, A Long German, A Lame Suburban and expensive dreams...
Missing all my previous B's, D's and V... Sad
American Ricer
www.badassofne.net
"Ooooh! Look! Something shiny!"
NO MORE UNICORNS!!!!!

LOWER IT!!! Wink
Back to top Go down
http://impalass.uniquekind.net/
Guest
Guest



PostSubject: Re: Anyone recognize this?   Tue Aug 11, 2009 10:03 pm

toomanytoyz wrote:
bammax wrote:
If you need a hand from someone that's done it before just ask.

Why... you know someone? Wink
They just putting em across the plate, and you keep knocking them out of the park. Razz
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Sat Aug 15, 2009 2:28 pm

OK guys put on your guessomatics
New fuel pump in, have pics of process but I'll post later if anyone cares.
Reasonable pressure 40psi first prime. 40 after start & solid. 45 pegged without regulator vacuum. Fluctuates slightly 38-40 reving but doesnt go higher. Is that right or should it increase with throttle? Also bleeds down as it sits which I dont get.
No visual leaks I did have to splice the lines at the tank as the 3/8 feed connector split during removal due to corrosion
Anyway so I get a clean start & runs fine under part throttle. Get her out for a short ride, shut her down & go right back into stumble no start & requires FULL throttle to start. Once started it runs OK but the start thing is bad. Guess away....please....

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: Anyone recognize this?   Sat Aug 15, 2009 2:54 pm

After doing the fuel pump you should change out the inline fuel filter (under the driverside door) since some debris will be stirred up in the system from the pump replacement process. After that if the problem is still there we can start guessing more items to look at.
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Sat Aug 15, 2009 3:18 pm

Did that before the pump trying to get lucky
Added piece of info on this 185K never gave me a problem BBB
Idle is up, wants to hold about 1100rpm. IAC never touched
NOT replaced coil,O2's, ICM, injectors, TPS, MAF, MAP. OPTI was at maybe 100k
So heres my guess, I'm bleeding off fuel pressure thru bad injector
Anyone ever have something like this happen? How do I see what injector is faulty?
Guess away

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6


Last edited by sdstick on Sun Aug 16, 2009 10:16 am; edited 3 times in total (Reason for editing : Added a guess & question)
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Anyone recognize this?   Sun Aug 16, 2009 1:24 pm

Anyone want to guess....ECT for PCM?......Hence the hot start problems & stumble.
Shoulda started with the simple.
Also changed the coil wire I left aside when I did the wires
Guess neglecting a vehicle gets you 1 way or the other.
Problem was NOTHING had been replaced, this car owes me NOTHING.
Well I have some fuel pump install pics anyway.
Will do new post later. Thanks for the input anyway helped easy the frustration.

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6


Last edited by sdstick on Sun Aug 16, 2009 1:25 pm; edited 1 time in total (Reason for editing : Forgot the coil wire)
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: Anyone recognize this?   Sun Aug 16, 2009 1:32 pm

Hopefully all is well now. Considering the fuel pressure readings before and after as well as the mileage on the unit I think the new pump was probably a good idea. It may have just been a matter of a couple small problems adding up to a single big issue as far as your car is concerned. I've seen cars that run like hell because the fuel filter is clogged and the timing is off and those combined make it seem like the engine is terminal. Keep us updated on the condition of your car after all of this work.
Back to top Go down
Sponsored content




PostSubject: Re: Anyone recognize this?   Today at 11:01 pm

Back to top Go down
 
Anyone recognize this?
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» tall plaster 20th century lamp - anyone recognize this??
» Anyone recognize this?
» Help! Anyone recognize an ITALY mark?!
» Need a little more low end in your system? Check out this woofer ..
» Help please! anyone recognize this signature?

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: