BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log inLog in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there are 2 users online :: 0 Registered, 0 Hidden and 2 Guests

None

Most users ever online was 101 on Fri Nov 27, 2015 1:40 pm
Latest topics
» 2012 and up Caprice PPV
Sat Dec 03, 2016 4:36 pm by No Moa

» I wasn't even looking for this one, I swear!
Thu Dec 01, 2016 9:52 am by 95brmw

» This forum needs a pulse check.... pics included
Tue Nov 29, 2016 1:04 pm by Grumpy

» 1994 Roadmaster Estate Wagon
Tue Nov 29, 2016 10:15 am by lvd2340

» Who're You callin a Turkey?
Thu Nov 24, 2016 1:32 pm by 802

» New Ride
Thu Nov 17, 2016 8:17 am by silverfox103

» Complete SS interior.
Thu Oct 27, 2016 1:35 pm by No Moa

» 2016 9th Annual Roundup, List of Attendees
Tue Oct 18, 2016 1:04 am by MASShole9C1

» Pictures from the 2016 Roundup
Mon Oct 17, 2016 8:03 pm by toomanytoyz

Search
 
 

Display results as :
 
Rechercher Advanced Search
December 2016
MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
262728293031 
CalendarCalendar

Share | 
 

 Who's had a Fuel Pump go bad on a b-body??

View previous topic View next topic Go down 
AuthorMessage
96Brougham



Posts : 819
Join date : 2009-02-02
Age : 28
Location : Easton MA

PostSubject: Who's had a Fuel Pump go bad on a b-body??   Mon Mar 01, 2010 10:46 pm

Here's whats up. Today was my first full day with my new 95 RMW. I drove it probably 100 miles today no issue. i got home and ran in the house for a minute, and then went to take my mother for a quick ride in it(because I just got it!). Go out to the car, cranks but wont start! I cycled the key and retried, again, just cranking! Now my mother doesnt want to drive in it and I'm pissed. I walk away. Go back out ten mins later, it starts! tried ten times in a row, started no issue. cool!

Now I've noticed the fuel pump doesnt have the loud buzzing/humming noise that it had yesterday and earlier today, its more of a lighter groan. I can hear it turn on, but not like it sounded earlier.. Do I need a fuel pump?? Does anybody have experience with this noise/no start problem?
Back to top Go down
Guest
Guest



PostSubject: Re: Who's had a Fuel Pump go bad on a b-body??   Mon Mar 01, 2010 10:54 pm

It sounds like it could be the pump. Check the fuse, and relay. Have the system pressure tested if you are not sure. But the next time this happens try giving the fuel tank a couple solid wacks with your foot or hand. If it starts after, your fuel pump is on it's way out.

I will say that keeping fuel at the half way mark or higher will increase the life of any fuel pump by keeping it cool while it runs.
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: Who's had a Fuel Pump go bad on a b-body??   Wed Mar 03, 2010 12:00 am

Mine changed pitch right before it started to fail. Then it started to fail. Usually pulling out into traffic when I put the pedal down. I'd say it may be time.

I also had a no start issue that was completely random and would make the VATS light come on. It turned out the fuse in the kick panel for the VATS was loose.
Back to top Go down
Sponsored content




PostSubject: Re: Who's had a Fuel Pump go bad on a b-body??   Today at 6:48 am

Back to top Go down
 
Who's had a Fuel Pump go bad on a b-body??
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Loud fuel pump in my olds 88
» Quick Fuel Pump swap
» Who's had a Fuel Pump go bad on a b-body??
» WHOS THE WIZZ KID ON DIESELS
» Lt1 long crank?

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: BADASS information :: Bad talk-
Jump to: