BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there is 1 user online :: 0 Registered, 0 Hidden and 1 Guest

None

Most users ever online was 132 on Wed Oct 04, 2017 3:26 pm
Latest topics
» In search of a 1996 knock module URGENT
Fri May 11, 2018 3:31 pm by fatvet

» Allagash Wilderness Waterway Canoe Trip 2018
Wed May 02, 2018 8:24 am by boojum

» Collected RMW stuff for 22 years--time for it to go!
Tue May 01, 2018 10:05 am by silverfox103

» HEY HOW AH YAH?
Wed Apr 25, 2018 4:28 pm by fatvet

» Looking for 91-96 RMW for sale
Mon Apr 23, 2018 12:21 pm by Wawa

» WTB: caprice taillights
Fri Apr 20, 2018 3:36 pm by fatvet

» Transmission temp sensor help..
Sun Mar 11, 2018 2:41 pm by Ironfistdog

» WTB: 235/70/R15 tires
Mon Jan 15, 2018 8:42 pm by demilo

» Triumph C 7000 Lift
Mon Jan 08, 2018 1:56 am by demilo

Search
 
 

Display results as :
 
Rechercher Advanced Search
May 2018
MonTueWedThuFriSatSun
 123456
78910111213
14151617181920
21222324252627
28293031   
CalendarCalendar

Share | 
 

 Who's had a Fuel Pump go bad on a b-body??

Go down 
AuthorMessage
96Brougham



Posts : 819
Join date : 2009-02-02
Age : 30
Location : Easton MA

PostSubject: Who's had a Fuel Pump go bad on a b-body??   Mon Mar 01, 2010 10:46 pm

Here's whats up. Today was my first full day with my new 95 RMW. I drove it probably 100 miles today no issue. i got home and ran in the house for a minute, and then went to take my mother for a quick ride in it(because I just got it!). Go out to the car, cranks but wont start! I cycled the key and retried, again, just cranking! Now my mother doesnt want to drive in it and I'm pissed. I walk away. Go back out ten mins later, it starts! tried ten times in a row, started no issue. cool!

Now I've noticed the fuel pump doesnt have the loud buzzing/humming noise that it had yesterday and earlier today, its more of a lighter groan. I can hear it turn on, but not like it sounded earlier.. Do I need a fuel pump?? Does anybody have experience with this noise/no start problem?
Back to top Go down
Guest
Guest



PostSubject: Re: Who's had a Fuel Pump go bad on a b-body??   Mon Mar 01, 2010 10:54 pm

It sounds like it could be the pump. Check the fuse, and relay. Have the system pressure tested if you are not sure. But the next time this happens try giving the fuel tank a couple solid wacks with your foot or hand. If it starts after, your fuel pump is on it's way out.

I will say that keeping fuel at the half way mark or higher will increase the life of any fuel pump by keeping it cool while it runs.
Back to top Go down
bammax

avatar

Posts : 2301
Join date : 2009-02-22
Age : 36
Location : Mansfield, Ma

PostSubject: Re: Who's had a Fuel Pump go bad on a b-body??   Wed Mar 03, 2010 12:00 am

Mine changed pitch right before it started to fail. Then it started to fail. Usually pulling out into traffic when I put the pedal down. I'd say it may be time.

I also had a no start issue that was completely random and would make the VATS light come on. It turned out the fuse in the kick panel for the VATS was loose.
Back to top Go down
Sponsored content




PostSubject: Re: Who's had a Fuel Pump go bad on a b-body??   

Back to top Go down
 
Who's had a Fuel Pump go bad on a b-body??
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: BADASS information :: Bad talk-
Jump to: