BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there is 1 user online :: 0 Registered, 0 Hidden and 1 Guest

None

Most users ever online was 132 on Wed Oct 04, 2017 3:26 pm
Latest topics
» 1980 coupe DeVille for sale
Thu Dec 07, 2017 6:20 pm by IMPALADAKID

» Stock radio wanted
Sun Nov 26, 2017 8:07 pm by silverfox103

» 96 SS console, shifter, cable, brackets
Mon Nov 20, 2017 4:01 pm by No Moa

» Lots of 77-79 B-body Parts New and Used
Mon Nov 06, 2017 3:08 pm by Rossj

» Pictures from the 2017 Roundup
Wed Oct 18, 2017 9:00 pm by Big Wagon Guy

» Brake line size help
Sun Oct 15, 2017 9:08 pm by 1984twodoor

» Surprise Surprise!
Sun Oct 15, 2017 8:17 pm by Big Wagon Guy

» 1980 Coupe De Ville
Sat Oct 14, 2017 8:55 pm by IMPALADAKID

» 2017 10th Annual Roundup, List of Attendees
Sat Oct 14, 2017 8:42 am by Big Wagon Guy

Search
 
 

Display results as :
 
Rechercher Advanced Search
December 2017
MonTueWedThuFriSatSun
    123
45678910
11121314151617
18192021222324
25262728293031
CalendarCalendar

Share | 
 

 Stumble/surge issue at Operating tempuratre at idle. Help.

View previous topic View next topic Go down 
AuthorMessage
Black93Caprice

avatar

Posts : 16
Join date : 2013-03-22
Location : Stoneham, MA

PostSubject: Stumble/surge issue at Operating tempuratre at idle. Help.   Fri Jun 28, 2013 2:03 pm

This is on the wife's 96 Caprice with a L99. When the car gets up to operating temperature, she will get a hesitation off the line and sometimes at a traffic light or at a complete stop it will surge up and also seem like it is going to stall. Any ideas? I can tell you what has been done so far. New EGR, and new TPS both with no changes. It is very pronounced if she runs the A/C.
Back to top Go down
silverfox103

avatar

Posts : 1503
Join date : 2009-01-25
Age : 22
Location : Littleton, NH & St. Simons Island, GA

PostSubject: Re: Stumble/surge issue at Operating tempuratre at idle. Help.   Fri Jun 28, 2013 2:28 pm

How many miles on the car

I think I would check the fuel pump pressure.

When is the last time it has had a tuneup?

Tom C.
Back to top Go down
Black93Caprice

avatar

Posts : 16
Join date : 2013-03-22
Location : Stoneham, MA

PostSubject: Re: Stumble/surge issue at Operating tempuratre at idle. Help.   Fri Jun 28, 2013 3:47 pm

There are 102K on it. I will check the fuel pressure this weekend. It runs like a bat out of hell until it gets up to ops temp and then it starts to act up but not all of the time.
Back to top Go down
Black93Caprice

avatar

Posts : 16
Join date : 2013-03-22
Location : Stoneham, MA

PostSubject: Re: Stumble/surge issue at Operating tempuratre at idle. Help.   Sun Jul 28, 2013 1:25 pm

OK. I finally got a chance to check the fuel pressure. At prime it is a solid 40 PSI. at startup/run it is 38 PSI with the fuel pressure regulator vacuum applied. With the vacuum blocked off at the regulator the pressure is 46 PSI and the idle is a little smoother and slightly higher in RPM.
Back to top Go down
Ironfistdog

avatar

Posts : 2124
Join date : 2011-01-11
Age : 36
Location : Warren, MA

PostSubject: Re: Stumble/surge issue at Operating tempuratre at idle. Help.   Sun Jul 28, 2013 6:35 pm

Check
-idle air control valve
-o2 sensors
-ground wires at the coil
-ground wire from back of block to firewall
-burned or loose spark plug wires

Any check engine lights?
Any funny sounds?
Back to top Go down
Black93Caprice

avatar

Posts : 16
Join date : 2013-03-22
Location : Stoneham, MA

PostSubject: Re: Stumble/surge issue at Operating tempuratre at idle. Help.   Sun Jul 28, 2013 9:35 pm

The only check engine light was a P0300 and that only tripped one time. The wife now says that sometimes it will buck a little on the highway. I have a new IAC that I can install. No funny sounds present. I will recheck the grounds and wires. Nothing looked out of the ordinary the last time I looked at them. I will do a little more digging and report back.
Thank you
Back to top Go down
Ironfistdog

avatar

Posts : 2124
Join date : 2011-01-11
Age : 36
Location : Warren, MA

PostSubject: Re: Stumble/surge issue at Operating tempuratre at idle. Help.   Sun Jul 28, 2013 10:15 pm

Sounds like an ignition problem.
Inspect wires and plugs
Inspect coil and the grounds
Might need new opti

Those would be the easy things.
Po300 could also be from burnt valve or headgasket on the way out.... But those are on the extreme end.

Run the car after dark and look for arcing.
Back to top Go down
Black93Caprice

avatar

Posts : 16
Join date : 2013-03-22
Location : Stoneham, MA

PostSubject: Re: Stumble/surge issue at Operating tempuratre at idle. Help.   Sun Aug 11, 2013 7:20 pm

Ok, I just checked all grounds near the coil/ICM and the rear of the motor. Everything looks good. I replaced the ICM and the coil and have the same issues. I am leaning towards the opti starting to shit the bed.
Back to top Go down
FUN-9C1

avatar

Posts : 146
Join date : 2009-05-09
Location : lakes region, NH

PostSubject: Re: Stumble/surge issue at Operating tempuratre at idle. Help.   Fri Sep 06, 2013 10:12 pm

When we bought our L99 new, from day 1 it would "hunt" a little at an idle, and about 1 out of 5 or 10 times I'd go to put it in reverse, it would stall. I took it to the dealer countless times and they never figured it out but we learned to live with it. One day at about 60k miles, I decided to take the TB apart and clean it. I did not have fixing this problem in mind, just figured it was due. After that, I noticed right away that it idled smooth, and it never stalled again! I didn't see a damn thing wrong with the TB, no "smoking gun" or anything, but that fixed it in my case.
Back to top Go down
sdstick

avatar

Posts : 4287
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Stumble/surge issue at Operating tempuratre at idle. Help.   Sat Sep 07, 2013 7:55 am

^^that sounds like you fixed a vacuum leak^^

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
Sponsored content




PostSubject: Re: Stumble/surge issue at Operating tempuratre at idle. Help.   

Back to top Go down
 
Stumble/surge issue at Operating tempuratre at idle. Help.
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Stumble and surge Any ideas? My head hurts
» Off the line stumble
» Did Victor Surge Actually Create Slender man
» BSR A29 changer issue
» Binding issue

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: