BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there is 1 user online :: 0 Registered, 0 Hidden and 1 Guest

None

Most users ever online was 132 on Wed Oct 04, 2017 3:26 pm
Latest topics
» 1980 coupe DeVille for sale
Thu Dec 07, 2017 6:20 pm by IMPALADAKID

» Stock radio wanted
Sun Nov 26, 2017 8:07 pm by silverfox103

» 96 SS console, shifter, cable, brackets
Mon Nov 20, 2017 4:01 pm by No Moa

» Lots of 77-79 B-body Parts New and Used
Mon Nov 06, 2017 3:08 pm by Rossj

» Pictures from the 2017 Roundup
Wed Oct 18, 2017 9:00 pm by Big Wagon Guy

» Brake line size help
Sun Oct 15, 2017 9:08 pm by 1984twodoor

» Surprise Surprise!
Sun Oct 15, 2017 8:17 pm by Big Wagon Guy

» 1980 Coupe De Ville
Sat Oct 14, 2017 8:55 pm by IMPALADAKID

» 2017 10th Annual Roundup, List of Attendees
Sat Oct 14, 2017 8:42 am by Big Wagon Guy

Search
 
 

Display results as :
 
Rechercher Advanced Search
December 2017
MonTueWedThuFriSatSun
    123
45678910
11121314151617
18192021222324
25262728293031
CalendarCalendar

Share | 
 

 Fuel pump relay ground issue

View previous topic View next topic Go down 
AuthorMessage
GasTT

avatar

Posts : 2675
Join date : 2009-01-19
Age : 29
Location : Treasure Coast, FL

PostSubject: Fuel pump relay ground issue   Mon Jun 03, 2013 6:47 pm

Working on a RMW for somebody. Fuel pump not working. I applied 12v to the test lead and got nothing. Diagnostics point toward fuel pump relay ground. I applied 12v to the test lead while grounding the sending unit right at the connector, still nothing. I know the pump is dead. But still, the relay is not grounding. Cleaned the drivers head front grounds at the coil still nothing. Any ideas?
Back to top Go down
sdstick

avatar

Posts : 4287
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Fuel pump relay ground issue   Mon Jun 03, 2013 10:13 pm

Drivers side kick panel ground is maybe the relay

Not sure where the sender ground is on a wagon...never looked...sorry

When you put 12v on the prime wire do you have 12V at the pump connector?

Check 12V to any ground back there

If you get 12V Make your own ground & see if the pumps any good

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
GasTT

avatar

Posts : 2675
Join date : 2009-01-19
Age : 29
Location : Treasure Coast, FL

PostSubject: Re: Fuel pump relay ground issue   Tue Jun 04, 2013 10:15 am

I have power at the rear connector grey wire when connected to the test lead. I applied 12v and ground directly to the pump side of the harness today and nothing. GWS fuel pump.
Back to top Go down
sdstick

avatar

Posts : 4287
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Fuel pump relay ground issue   Tue Jun 04, 2013 10:27 am

Exactly

Hopefully fuel connections, straps & bolts are still servicable

Did 2 (Matts & mine) in 4 hours the other day

Took me 1/2 hour (+) to eventually yank the 3/8 connection apart on my DD

Whoever replaced it bent 1 of the 4 legs of the internal snap retainer ( OEM metal connection)....SOB...not much blood when it let go luckily... Laughing

I also had to balance the heat shields during re-install because of how Matts exhaust runs...PIA

I was SOoooo happy I had anti-siezed every bolt in Matts & my DD wasnt beyond.


_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
boojum



Posts : 2167
Join date : 2009-01-21
Age : 30
Location : NH

PostSubject: Re: Fuel pump relay ground issue   Tue Jun 04, 2013 8:41 pm

GasTT wrote:
I have power at the rear connector grey wire when connected to the test lead. I applied 12v and ground directly to the pump side of the harness today and nothing. GWS fuel pump.

Try to reverse the polarity briefly and back a few times.
Back to top Go down
GasTT

avatar

Posts : 2675
Join date : 2009-01-19
Age : 29
Location : Treasure Coast, FL

PostSubject: Re: Fuel pump relay ground issue   Tue Jun 04, 2013 11:09 pm

Ill give it a shot
Back to top Go down
Sponsored content




PostSubject: Re: Fuel pump relay ground issue   

Back to top Go down
 
Fuel pump relay ground issue
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Loud fuel pump in my olds 88
» Quick Fuel Pump swap
» Who's had a Fuel Pump go bad on a b-body??
» Lt1 long crank?
» opti?fuel pump? SHIT THE BED

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: