BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log inLog in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there are 4 users online :: 0 Registered, 0 Hidden and 4 Guests

None

Most users ever online was 101 on Fri Nov 27, 2015 1:40 pm
Latest topics
» 2012 and up Caprice PPV
Sat Dec 03, 2016 4:36 pm by No Moa

» I wasn't even looking for this one, I swear!
Thu Dec 01, 2016 9:52 am by 95brmw

» This forum needs a pulse check.... pics included
Tue Nov 29, 2016 1:04 pm by Grumpy

» 1994 Roadmaster Estate Wagon
Tue Nov 29, 2016 10:15 am by lvd2340

» Who're You callin a Turkey?
Thu Nov 24, 2016 1:32 pm by 802

» New Ride
Thu Nov 17, 2016 8:17 am by silverfox103

» Complete SS interior.
Thu Oct 27, 2016 1:35 pm by No Moa

» 2016 9th Annual Roundup, List of Attendees
Tue Oct 18, 2016 1:04 am by MASShole9C1

» Pictures from the 2016 Roundup
Mon Oct 17, 2016 8:03 pm by toomanytoyz

Search
 
 

Display results as :
 
Rechercher Advanced Search
December 2016
MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
262728293031 
CalendarCalendar

Share | 
 

 this is my opti story......

View previous topic View next topic Go down 
AuthorMessage
mikiehews



Posts : 372
Join date : 2011-02-03
Age : 41
Location : brockton

PostSubject: this is my opti story......   Thu Jan 17, 2013 7:41 pm

I hope by posting this it helps someone avoid the agrivation I went thru.
My problems started last thursday after coming out of the car wash I couldn't get my car started. I popped the hood
and smelled gas. First thought is its flooded. Not sure why! I took off the air cleaner to help dry out the gas. Several attepts failed to start the car. So I held the throttle to the floor which resulted in a huge backfire. So bad it blew the seem apart on the right side muffler. I eventually got the car started and went back to work. I drove home that nite, to and from work on friday with no problem. Monday morning she wouldn't fire. Many attempts with no success. Again a strong oder of fuel. I tried using a "starting fluid", nothing! I called a tow truck ( I had to get to work). I let the car sit awhile after a few hours I tried starting it again.
Nothing but fuel smell. I replaced ( no check engine lite BTW) the coil and ignition module. Still nothing. I had to hook up the battery charger and tried again. It started but blew a huge cloud of blue smoke. It ran good for awhile then died.
Later I got in in the shop (under its own power) and started checking everything. I noticed a check engine lite (finally)
and the fans started running even thou the engine was cold. I replaced the coolant temp sensor Just incase. It ran good so I backed it outta the shop then it died again. Back in the shop I checked for fuel pressure (37-45 psi). Checked ignition. Big spark from coil little from opti. More dia was needed the following day. My wife had to pick me up. Next day I orded spark plugs, wires and a complete opti. 4 hours later I had the left bank of plugs, wires and opti done. Still no start. The old opti BTW was dry but looked like it needed replacing. After much thought alittle research and little sleep, the next day I pulled the opti back to see I had the rotor in the wrong spot. The timing was off by 33.3 degrees. I that I had it fixed! Still no start. Big fuel smell so I unplugged the fuel pump relay turned on the battery charger
and cranked the shit outta it! 20 minutes later it started.Fuel shot out of the intake causing alittle fire on the engine and a ton of smoke out of the tail pipes. Finally 3 days later it was running but like crap. Then it died again. One of my techs unplugged
the mass air flow sensor. It started up and ran pissa! I did have a check engine lite again. I plugged back in the MAF sensor
and it died. So that nite I drove it home without the MAF. It drove ok. I went very slow. Next day I replaced the MAF with an updated unit from GM. The engine lite went out and the car drove excellant. I also had the blown out muffler replaced. Actuallty
I had meinekee replace both with flow master knock-offs. I had spent enuff money! I think in retrospect the mass air flow
was the begining of my problems but overlooked it. Either way the opti needed replacing along with the plugs and wires so I
don't know what the problem really was. Maybe a combination of eveything. I know this story is poorly writen Smile but I would love to here any and all thoughts. Also I can remove an opti in my sleep if anyone ever needs help!



Back to top Go down
Heatherbelle



Posts : 3
Join date : 2013-01-17
Location : Rhode Island

PostSubject: Re: this is my opti story......   Thu Jan 17, 2013 7:46 pm

I am having the same kinda problem with my 96 ImpSS. I Do have a question for you, I'm gonna sound like a dumb broad probably but here it goes. What is an Opti? I don't think I've heard of this before.
Back to top Go down
mikiehews



Posts : 372
Join date : 2011-02-03
Age : 41
Location : brockton

PostSubject: Re: this is my opti story......   Thu Jan 17, 2013 7:51 pm

after I red my story I never mentioned how fustrating of encounter this was for me and my wife. My purpala is my baby and daily driver.
My wife and me had to share a car for three days and had to make comprimises. My GM from my dealership
wanted to sell me a new car! He said its time to give up on this car. I said "really, I can barley afford what I have, never mind a 300 a month car payment"
He said "you can't afford 300 extra a month". I said "nope". He does't understand what its like to live paycheck to paycheck.
Many of us do work on our cars ourselves and pride ourselves on keeping these cars alive. I bet my impala
will outlast any new car he could sell me!
Back to top Go down
mikiehews



Posts : 372
Join date : 2011-02-03
Age : 41
Location : brockton

PostSubject: Re: this is my opti story......   Thu Jan 17, 2013 7:56 pm

Heatherbelle wrote:
I am having the same kinda problem with my 96 ImpSS. I Do have a question for you, I'm gonna sound like a dumb broad probably but here it goes. What is an Opti? I don't think I've heard of this before.

Its not a dumb question. I work with some of the most highly trained techs I've ever met and they couldn't help me.

The "opti" is the same as a distributer just mounted on the front of the LT1 not on top of the motor like it was done for decades prior. Google it! There is soo much info out there that can explain much better than I can!
Back to top Go down
toomanytoyz
Club President


Posts : 6870
Join date : 2009-01-20
Age : 40
Location : East Hampstead, NH USA

PostSubject: Re: this is my opti story......   Thu Jan 17, 2013 8:02 pm

Heatherbelle wrote:
I am having the same kinda problem with my 96 ImpSS. I Do have a question for you, I'm gonna sound like a dumb broad probably but here it goes. What is an Opti? I don't think I've heard of this before.

The "opti" is the Optispark, which is GM-speak for the new style distributor mounting on the front of the engine, under the waterpump. Most times, when you get funky run/no run conditions, the opti is to blame and used to commonly be replaced as an entire unit, as no cap and rotor kit was easily or cheaply accessible. When you pull your old one and it's dry inside, you probably just need a cap and rotor and can reuse the optics. And welcome aboard! Smile

As far as your whole ordeal, Mike... Flames and fire are cool!!!! Very Happy

Seriously though, that stinks. But for future reference... If the CEL comes on and the fans are on, chances are it's the MAF. What code was it? Smile But now you know.

_________________
Bill "The Verb" Crovo - Resident Car Slut & Unicorn Hunter

A Toasted Marshmallow, A Long German, A Lame Suburban and expensive dreams...
Missing all my previous B's, D's and V... Sad
American Ricer
www.badassofne.net
"Ooooh! Look! Something shiny!"
NO MORE UNICORNS!!!!!

LOWER IT!!! Wink
Back to top Go down
http://impalass.uniquekind.net/
Heatherbelle



Posts : 3
Join date : 2013-01-17
Location : Rhode Island

PostSubject: Re: this is my opti story......   Thu Jan 17, 2013 8:06 pm

mikiehews wrote:
Heatherbelle wrote:
I am having the same kinda problem with my 96 ImpSS. I Do have a question for you, I'm gonna sound like a dumb broad probably but here it goes. What is an Opti? I don't think I've heard of this before.

Its not a dumb question. I work with some of the most highly trained techs I've ever met and they couldn't help me.

The "opti" is the same as a distributer just mounted on the front of the LT1 not on top of the motor like it was done for decades prior. Google it! There is soo much info out there that can explain much better than I can!
Thank you. Ill take a look at google. I'm getting so aggregated people telling me to check relay and all fuel related fuses. I bought for sure it was fuel pump, but replaced that yesterday, and still won't stay running. He reason I say it's similar to yours is because before it just stop running it was doing the same asylums, backfiring and running like shit. Thanks for info
Back to top Go down
Heatherbelle



Posts : 3
Join date : 2013-01-17
Location : Rhode Island

PostSubject: Re: this is my opti story......   Thu Jan 17, 2013 8:08 pm

toomanytoyz wrote:
Heatherbelle wrote:
I am having the same kinda problem with my 96 ImpSS. I Do have a question for you, I'm gonna sound like a dumb broad probably but here it goes. What is an Opti? I don't think I've heard of this before.

The "opti" is the Optispark, which is GM-speak for the new style distributor mounting on the front of the engine, under the waterpump. Most times, when you get funky run/no run conditions, the opti is to blame and used to commonly be replaced as an entire unit, as no cap and rotor kit was easily or cheaply accessible. When you pull your old one and it's dry inside, you probably just need a cap and rotor and can reuse the optics. And welcome aboard! Smile

As far as your whole ordeal, Mike... Flames and fire are cool!!!! Very Happy

Seriously though, that stinks. But for future reference... If the CEL comes on and the fans are on, chances are it's the MAF. What code was it? Smile But now you know.
Thanks for the welcome. I am going to have to look into to this Opti.
Back to top Go down
No Moa



Posts : 3871
Join date : 2009-02-21
Age : 44
Location : Midcoast Maine

PostSubject: Re: this is my opti story......   Thu Jan 17, 2013 9:11 pm

Welcome, it's a more laid back here.
Back to top Go down
http://www.collectorfbody.com
mikiehews



Posts : 372
Join date : 2011-02-03
Age : 41
Location : brockton

PostSubject: Re: this is my opti story......   Thu Jan 17, 2013 10:19 pm

Heatherbelle wrote:
mikiehews wrote:
Heatherbelle wrote:
I am having the same kinda problem with my 96 ImpSS. I Do have a question for you, I'm gonna sound like a dumb broad probably but here it goes. What is an Opti? I don't think I've heard of this before.

Its not a dumb question. I work with some of the most highly trained techs I've ever met and they couldn't help me.

The "opti" is the same as a distributer just mounted on the front of the LT1 not on top of the motor like it was done for decades prior. Google it! There is soo much info out there that can explain much better than I can!
Thank you. Ill take a look at google. I'm getting so aggregated people telling me to check relay and all fuel related fuses. I bought for sure it was fuel pump, but replaced that yesterday, and still won't stay running. He reason I say it's similar to yours is because before it just stop running it was doing the same asylums, backfiring and running like shit. Thanks for info

flames and fire are cool! I can't tell you how hard I laughed when I heard about the flames! Live and learn!
Back to top Go down
mikiehews



Posts : 372
Join date : 2011-02-03
Age : 41
Location : brockton

PostSubject: Re: this is my opti story......   Thu Jan 17, 2013 10:25 pm

Heatherbelle wrote:
toomanytoyz wrote:
Heatherbelle wrote:
I am having the same kinda problem with my 96 ImpSS. I Do have a question for you, I'm gonna sound like a dumb broad probably but here it goes. What is an Opti? I don't think I've heard of this before.

The "opti" is the Optispark, which is GM-speak for the new style distributor mounting on the front of the engine, under the waterpump. Most times, when you get funky run/no run conditions, the opti is to blame and used to commonly be replaced as an entire unit, as no cap and rotor kit was easily or cheaply accessible. When you pull your old one and it's dry inside, you probably just need a cap and rotor and can reuse the optics. And welcome aboard! Smile

As far as your whole ordeal, Mike... Flames and fire are cool!!!! Very Happy

Seriously though, that stinks. But for future reference... If the CEL comes on and the fans are on, chances are it's the MAF. What code was it? Smile But now you know.
Thanks for the welcome. I am going to have to look into to this Opti.
Heatherbelle, let me know what and where you are taking your car!
Back to top Go down
Sponsored content




PostSubject: Re: this is my opti story......   Today at 3:22 am

Back to top Go down
 
this is my opti story......
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Opti replace and more 101
» The Stairway to Triumph - the story of Anne Boleyn
» A Short Imperial Guard Story [revised]
» Cleaning the opti vent harness
» Karottenkrieg - A German Warhammer/Mordheim-Story

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: