BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log inLog in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there are 4 users online :: 0 Registered, 0 Hidden and 4 Guests

None

Most users ever online was 101 on Fri Nov 27, 2015 1:40 pm
Latest topics
» 2012 and up Caprice PPV
Sat Dec 03, 2016 4:36 pm by No Moa

» I wasn't even looking for this one, I swear!
Thu Dec 01, 2016 9:52 am by 95brmw

» This forum needs a pulse check.... pics included
Tue Nov 29, 2016 1:04 pm by Grumpy

» 1994 Roadmaster Estate Wagon
Tue Nov 29, 2016 10:15 am by lvd2340

» Who're You callin a Turkey?
Thu Nov 24, 2016 1:32 pm by 802

» New Ride
Thu Nov 17, 2016 8:17 am by silverfox103

» Complete SS interior.
Thu Oct 27, 2016 1:35 pm by No Moa

» 2016 9th Annual Roundup, List of Attendees
Tue Oct 18, 2016 1:04 am by MASShole9C1

» Pictures from the 2016 Roundup
Mon Oct 17, 2016 8:03 pm by toomanytoyz

Search
 
 

Display results as :
 
Rechercher Advanced Search
December 2016
MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
262728293031 
CalendarCalendar

Share | 
 

 She Doesn't Run No More

View previous topic View next topic Go down 
AuthorMessage
QwikImpSS



Posts : 164
Join date : 2009-02-16
Age : 32
Location : Pembroke, NH

PostSubject: She Doesn't Run No More   Mon May 11, 2009 3:19 pm

So I was on may way to meet friends on Friday to see Star Trek in iMax when my Impala died. Just straight up, flat out died on my when I was doing about 35-40.

My engine light had been on for a while (I was worried that she'd fail inspection because of it) and when I glanced down to check my guages when she shut off I noticed it wasn't on anymore. So, the engine MIL doesn't come on with KOEO (key on-engine off) leading me to believe that my PCM crapped out on me. Would I be correct in my assumption?

And Star Trek was AWESOME!!! Altho seeing it on opening night in the first showing in iMax was a mistake, a lot of virgin dorks around!!!!

And how flippin expensive are those things?!?! (PCMs I mean, not virgins)
Back to top Go down
Guest
Guest



PostSubject: Re: She Doesn't Run No More   Mon May 11, 2009 4:04 pm

QwikImpSS wrote:
So I was on may way to meet friends on Friday to see Star Trek in iMax when my Impala died. Just straight up, flat out died on my when I was doing about 35-40.

My engine light had been on for a while (I was worried that she'd fail inspection because of it) and when I glanced down to check my guages when she shut off I noticed it wasn't on anymore. So, the engine MIL doesn't come on with KOEO (key on-engine off) leading me to believe that my PCM crapped out on me. Would I be correct in my assumption?

And Star Trek was AWESOME!!! Altho seeing it on opening night in the first showing in iMax was a mistake, a lot of virgin dorks around!!!!

And how flippin expensive are those things?!?! (PCMs I mean, not virgins)
Check for spark and fuel first. pcm last. PCMs do not go bad that often.
Back to top Go down
QwikImpSS



Posts : 164
Join date : 2009-02-16
Age : 32
Location : Pembroke, NH

PostSubject: Re: She Doesn't Run No More   Mon May 11, 2009 4:10 pm

Yeah, I gotta go thru and do the basics but the lack of the engine light coming on at key on-engine off really bugs me.....
Back to top Go down
Guest
Guest



PostSubject: Re: She Doesn't Run No More   Mon May 11, 2009 4:14 pm

QwikImpSS wrote:
Yeah, I gotta go thru and do the basics but the lack of the engine light coming on at key on-engine off really bugs me.....
The bulb may have burned out, but it could be a failed pcm.
Back to top Go down
QwikImpSS



Posts : 164
Join date : 2009-02-16
Age : 32
Location : Pembroke, NH

PostSubject: Re: She Doesn't Run No More   Mon May 11, 2009 4:20 pm

It would be one hell of a coincidence for a burned-out bulb!
Back to top Go down
Guest
Guest



PostSubject: Re: She Doesn't Run No More   Mon May 11, 2009 4:29 pm

QwikImpSS wrote:
It would be one hell of a coincidence for a burned-out bulb!
Yes it would. But I would look at the basics first.
Back to top Go down
FUN-9C1



Posts : 145
Join date : 2009-05-09
Location : lakes region, NH

PostSubject: Re: She Doesn't Run No More   Mon May 11, 2009 9:52 pm

The first thing that pops into my head when I hear a motor just quit suddenly like you turned the key off is a bad coil. Happened to me once in Ol' Statey. IIRC it's about a 2 minute job to change one out if you have an extra or switch temporarily with a buddy to see if that's the problem.
Back to top Go down
Guest
Guest



PostSubject: Re: She Doesn't Run No More   Mon May 11, 2009 10:09 pm

FUN-9C1 wrote:
The first thing that pops into my head when I hear a motor just quit suddenly like you turned the key off is a bad coil. Happened to me once in Ol' Statey. IIRC it's about a 2 minute job to change one out if you have an extra or switch temporarily with a buddy to see if that's the problem.
Also look at the three wires that connect to the coil. They break inside the insulation, and you can not visually see the problem.
This happend on the FEDSLED.
Back to top Go down
Pooge



Posts : 1698
Join date : 2009-03-24

PostSubject: Re: She Doesn't Run No More   Mon May 11, 2009 10:10 pm

What year is the car?

Check the basics and if you still think it is the PCM, I have a 94 that I am selling with a swap, but I have been sitting on it for a while... If you need it to test or run for a few days till you get another, I can get it over to you...UPS is next day in New England for ground, for for like $7 each way you can test...

i think going rate is around $75 for a PCM plus shipping...but check the basics before you go scouting for one...

Doug
Back to top Go down
onehunglo



Posts : 315
Join date : 2009-01-25
Age : 38
Location : Raymond, NH

PostSubject: Re: She Doesn't Run No More   Wed May 13, 2009 6:54 am

[quote="QwikImpSS"]So I was on may way to meet friends on Friday to see Star Trek in iMax when my Impala died. Just straight up, flat out died on my when I was doing about 35-40.

Any diagnosis on the BeaSSt? scratch
Back to top Go down
Tomz9C1



Posts : 1486
Join date : 2009-01-21
Age : 53
Location : Rumford, Maine

PostSubject: Re: She Doesn't Run No More   Wed May 13, 2009 8:48 am

Have you done the Aux battery post mod? My 949C1 & 95B4U HAD this problem . Got two kits from Dal, $30 or so. RMS Auto is the source on ISSF. I'll try to get some Pics up.
Back to top Go down
Guest
Guest



PostSubject: Re: She Doesn't Run No More   Wed May 13, 2009 8:55 am

Tomz9C1 wrote:
Have you done the Aux battery post mod? My 949C1 & 95B4U HAD this problem . Got two kits from Dal, $30 or so. RMS Auto is the source on ISSF. I'll try to get some Pics up.
Another good place to look. My first 94 SS had this problem at 56k.
Back to top Go down
QwikImpSS



Posts : 164
Join date : 2009-02-16
Age : 32
Location : Pembroke, NH

PostSubject: Re: She Doesn't Run No More   Thu May 14, 2009 6:05 pm

No, I haven't done that mod. No answers as far as a diagnosis goes. I've either been incredibly lazy after work or I've been out fishing. I need to, but when I find out what's wrong I won't be able to afford to fix it.
Back to top Go down
QwikImpSS



Posts : 164
Join date : 2009-02-16
Age : 32
Location : Pembroke, NH

PostSubject: Re: She Doesn't Run No More   Sat May 16, 2009 12:04 pm

I started poking around today, trying to find the problem. I have a spark plug pulled ready to check for spark but, of course, I'm home alone with no one to crank her.



One troubling thing I noticed. My #1 suspicion is still the PCM so I pulled out the airbox (will probably drill some holes in it while it's out) to check and make sure the PCM is still hooked up and no connectors worked loose since I have heard of it happening before when I noticed I could just reach down and pick the PCM up. That's not supposed to happen, the tray is so rusty-rotten that it has just been sitting there. I'm thinking that the vibrations/rattling/banging around could have possibly caused premature PCM failure....just a thought but I'm not trying to point fingers just yet.


How do I check to make sure I have fuel at the injectors on this thing?
Back to top Go down
Guest
Guest



PostSubject: Re: She Doesn't Run No More   Sat May 16, 2009 12:35 pm

QwikImpSS wrote:
I started poking around today, trying to find the problem. I have a spark plug pulled ready to check for spark but, of course, I'm home alone with no one to crank her.



One troubling thing I noticed. My #1 suspicion is still the PCM so I pulled out the airbox (will probably drill some holes in it while it's out) to check and make sure the PCM is still hooked up and no connectors worked loose since I have heard of it happening before when I noticed I could just reach down and pick the PCM up. That's not supposed to happen, the tray is so rusty-rotten that it has just been sitting there. I'm thinking that the vibrations/rattling/banging around could have possibly caused premature PCM failure....just a thought but I'm not trying to point fingers just yet.


How do I check to make sure I have fuel at the injectors on this thing?
Turn the key to the on position and listen for a slight hum from the rear. This will let you know the pump is working. The hum will last about 1-2 seconds, and if you do not hear ir the pump, fuse, or harness in the tank are bad. Robins Auto parts carries both the pump and the harness from AC Delco if that is the problem. I have a spare coil and ignition module I could send ya if needed. It is in working order, so if you find that has crapped out LMK.
Back to top Go down
QwikImpSS



Posts : 164
Join date : 2009-02-16
Age : 32
Location : Pembroke, NH

PostSubject: Re: She Doesn't Run No More   Sat May 16, 2009 2:17 pm

The pump is the first thing I checked when she crapped out on me. It's working fine.

I'm gonna check for spark when my fiance gets home from work.
Back to top Go down
QwikImpSS



Posts : 164
Join date : 2009-02-16
Age : 32
Location : Pembroke, NH

PostSubject: Re: She Doesn't Run No More   Sat May 16, 2009 3:11 pm

OK!

No spark!

(Double checked the fuel pump)

No fuel!
Back to top Go down
Sponsored content




PostSubject: Re: She Doesn't Run No More   Today at 3:22 am

Back to top Go down
 
She Doesn't Run No More
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: