BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log inLog in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there are 3 users online :: 0 Registered, 0 Hidden and 3 Guests

None

Most users ever online was 101 on Fri Nov 27, 2015 1:40 pm
Latest topics
» 2012 and up Caprice PPV
Sat Dec 03, 2016 4:36 pm by No Moa

» I wasn't even looking for this one, I swear!
Thu Dec 01, 2016 9:52 am by 95brmw

» This forum needs a pulse check.... pics included
Tue Nov 29, 2016 1:04 pm by Grumpy

» 1994 Roadmaster Estate Wagon
Tue Nov 29, 2016 10:15 am by lvd2340

» Who're You callin a Turkey?
Thu Nov 24, 2016 1:32 pm by 802

» New Ride
Thu Nov 17, 2016 8:17 am by silverfox103

» Complete SS interior.
Thu Oct 27, 2016 1:35 pm by No Moa

» 2016 9th Annual Roundup, List of Attendees
Tue Oct 18, 2016 1:04 am by MASShole9C1

» Pictures from the 2016 Roundup
Mon Oct 17, 2016 8:03 pm by toomanytoyz

Search
 
 

Display results as :
 
Rechercher Advanced Search
December 2016
MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
262728293031 
CalendarCalendar

Share | 
 

 Engine problem 5l TBI

View previous topic View next topic Go down 
AuthorMessage
MarcinV8



Posts : 23
Join date : 2011-11-22
Age : 32
Location : Poland

PostSubject: Engine problem 5l TBI   Sat Feb 18, 2012 9:38 am

I have some problem. The Engine rpm waves and in the end the engine dies. It happens most times when it is warm.
Here you play some movies and hear it yourself. Any ideas what may be the cause?


Back to top Go down
Guest
Guest



PostSubject: Re: Engine problem 5l TBI   Sat Feb 18, 2012 10:49 am

Sound like either a fueling issue, or your intake manifold gasket is leaking. I would pull some plugs after it dies, and check to see if there is any moisture on them. I would also check your oil condition, and pull the distributer cap, and look for any funny burn patterns or worn terminals. Try replacing the fuel filter. A clogged filter can work fine during initial startup, but as the car starts to warm, any free flow in the filter gets quickly clogged, once it sits not running for awhile, the particles fall back down allowing fuel flow again.

So I would start by checking the fuel filter, and the intake manifold gasket, look for a vacuum leak? Check the EGR if so equipped
Back to top Go down
MarcinV8



Posts : 23
Join date : 2011-11-22
Age : 32
Location : Poland

PostSubject: Re: Engine problem 5l TBI   Sat Feb 18, 2012 10:52 am

Appreciated. I will check all the things you mentioned.
Back to top Go down
95brmw



Posts : 1431
Join date : 2009-11-10
Age : 32
Location : Connecticut

PostSubject: Re: Engine problem 5l TBI   Sat Feb 18, 2012 11:42 am

Also pull the air cleaner box off and see what the spray pattern looks like. Should be a nice cone from both injectors.
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Engine problem 5l TBI   Sat Feb 18, 2012 12:43 pm

We've learned to ask the question.....
Have you done anything to the motor lately?
Or did this just start out of the blue?

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
MarcinV8



Posts : 23
Join date : 2011-11-22
Age : 32
Location : Poland

PostSubject: Re: Engine problem 5l TBI   Sun Feb 19, 2012 4:12 am

Out of the blue
Back to top Go down
nttyfufu



Posts : 122
Join date : 2012-02-19
Age : 35
Location : Wilmington, Ma

PostSubject: Re: Engine problem 5l TBI   Wed Feb 22, 2012 4:36 pm

Just a guess but check out the idle speed control or Throttle position sensor going bad and seacrhing for signal?
Back to top Go down
http://s1078.photobucket.com/albums/w495/nttyfufu/
MarcinV8



Posts : 23
Join date : 2011-11-22
Age : 32
Location : Poland

PostSubject: Re: Engine problem 5l TBI   Thu Feb 23, 2012 2:05 pm

Problem solved - loose timing chain.
Back to top Go down
nttyfufu



Posts : 122
Join date : 2012-02-19
Age : 35
Location : Wilmington, Ma

PostSubject: Re: Engine problem 5l TBI   Thu Feb 23, 2012 2:27 pm

Ya That will do it. Glad you figured it out.
Back to top Go down
http://s1078.photobucket.com/albums/w495/nttyfufu/
MarcinV8



Posts : 23
Join date : 2011-11-22
Age : 32
Location : Poland

PostSubject: Re: Engine problem 5l TBI   Thu Feb 23, 2012 2:34 pm

nttyfufu wrote:
Ya That will do it. Glad you figured it out.
It's not the end of repairs, the car still drives sluggish, it doesn't accelerate like healthy TBI. I'm waiting for timing chain shipping (about 12 days) and than we will try to figure out why he is so slow.
Back to top Go down
MarcinV8



Posts : 23
Join date : 2011-11-22
Age : 32
Location : Poland

PostSubject: Re: Engine problem 5l TBI   Thu Mar 01, 2012 3:12 pm

The engine is Goodwrench crate engine 350 not the stock 305. Computer is from 305 - this may be the problem!
Back to top Go down
nttyfufu



Posts : 122
Join date : 2012-02-19
Age : 35
Location : Wilmington, Ma

PostSubject: Re: Engine problem 5l TBI   Thu Mar 01, 2012 4:18 pm

I would think if it's just a stock low end goodwrench replacement engine that the 305 comp. would be fine. Not ideal but fine. I have no direct expiriance with this situation but that's what i've heard.
Back to top Go down
http://s1078.photobucket.com/albums/w495/nttyfufu/
Guest
Guest



PostSubject: Re: Engine problem 5l TBI   Thu Mar 01, 2012 4:25 pm

MarcinV8 wrote:
The engine is Goodwrench crate engine 350 not the stock 305. Computer is from 305 - this may be the problem!
Sounds like you have an issue with the ecm. You need a custom chip made for your car.
Back to top Go down
MarcinV8



Posts : 23
Join date : 2011-11-22
Age : 32
Location : Poland

PostSubject: Re: Engine problem 5l TBI   Thu Mar 01, 2012 4:46 pm

IMPALADAKID wrote:
MarcinV8 wrote:
The engine is Goodwrench crate engine 350 not the stock 305. Computer is from 305 - this may be the problem!
Sounds like you have an issue with the ecm. You need a custom chip made for your car.
My friend started to work on custom software for the computer.
Back to top Go down
MarcinV8



Posts : 23
Join date : 2011-11-22
Age : 32
Location : Poland

PostSubject: Re: Engine problem 5l TBI   Tue Nov 13, 2012 10:44 am

Repaired!! Old engine is just scrap now, everything inside was broken... now my SW has 5.0 TBI with 54 000 miles on it. Runs great Very Happy
Back to top Go down
sdstick



Posts : 4278
Join date : 2009-03-20
Location : Revere, MA

PostSubject: Re: Engine problem 5l TBI   Tue Nov 13, 2012 11:29 am

Glad your problems are solved Arrow

Testament to the small block....
Runs even with:
MarcinV8 wrote:
............ everything inside was broken... Very Happy
.. cheers .. Razz

_________________
Steve


96BBB 28K 3.42 Bolt-ons
95BBB 100K 3.73 383 New DD...already broke fixt the 4L60E twice
95 Black WB4 Hole...ee...grail
96 Black WB4 No holes in this
95BBB 189K 3.08 Old DD Stolen...by Matt. Cool
Whine..eee...Silver LS6
Back to top Go down
MarcinV8



Posts : 23
Join date : 2011-11-22
Age : 32
Location : Poland

PostSubject: Re: Engine problem 5l TBI   Tue Nov 13, 2012 11:32 am

sdstick wrote:
Glad your problems are solved Arrow

Testament to the small block....
Runs even with:
MarcinV8 wrote:
............ everything inside was broken... Very Happy
.. cheers .. Razz
True, it worked but after the engine was open the cost of repairing it was higher than buying new engine.
Back to top Go down
Sponsored content




PostSubject: Re: Engine problem 5l TBI   Today at 8:58 pm

Back to top Go down
 
Engine problem 5l TBI
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Four .049 engine powered tether racer?
» Problem with my Petter. AVA
» Villiers problem!!
» Coborn Engine
» Cold engine stumble, with drivers little backfire

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: