BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log inLog in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there is 1 user online :: 0 Registered, 0 Hidden and 1 Guest

None

Most users ever online was 105 on Fri Mar 24, 2017 9:02 am
Latest topics
» 2017 Kancamagus Ride
Tue May 23, 2017 11:13 am by silverfox103

» Buick rear seat wanted (again)
Mon May 15, 2017 10:39 pm by MASShole9C1

» Midnight tour of the Allagash Ice Caves July 3rd!
Sun May 14, 2017 2:01 pm by booth9C1SS

» Dust off / hang out / mod day at my house May 20th
Sun May 14, 2017 11:10 am by toomanytoyz

» Spindles
Wed Apr 26, 2017 8:41 pm by MalibuSSwagon

» New Ride, New Forum!
Thu Apr 13, 2017 12:08 am by boojum

» '95 DCM RMW
Sat Apr 08, 2017 2:02 pm by Bull

» Is it just me or does impalassforum suck?
Thu Apr 06, 2017 8:48 am by toomanytoyz

» 94 RMS 60k miles and 94 FWB with 76k for sale
Fri Mar 31, 2017 4:41 pm by CrashMaster

Search
 
 

Display results as :
 
Rechercher Advanced Search
May 2017
MonTueWedThuFriSatSun
1234567
891011121314
15161718192021
22232425262728
293031    
CalendarCalendar

Share | 
 

 Broken Gauge cluster?

View previous topic View next topic Go down 
AuthorMessage
JW94SSLT1

avatar

Posts : 20
Join date : 2011-02-27
Age : 33
Location : Windham, ME

PostSubject: Broken Gauge cluster?   Wed Sep 07, 2011 7:23 am

I'm not sure what to do my speed and gas gauge work but nothing else Ive changed the cluster out once and nothing changed I have no engine temp it always reads cold and oil pressure reads nothing and the volts is high all the time any ideas should i just change to a z cluster?
Back to top Go down
No Moa

avatar

Posts : 3886
Join date : 2009-02-21
Age : 44
Location : Midcoast Maine

PostSubject: Re: Broken Gauge cluster?   Wed Sep 07, 2011 8:42 am

Did you change the WHOLE cluster? or just the speedo piece?

I'd look at fuses first, then remove the whole assembly and clean the contacts. Maybe they are corroded a litte, i know mine in the 96 where.

Let me know what you need, i have a couple cars left with clusters. Come up and take a couple to try if you want.

Glen
Back to top Go down
http://www.collectorfbody.com
JW94SSLT1

avatar

Posts : 20
Join date : 2011-02-27
Age : 33
Location : Windham, ME

PostSubject: Broken Gauge cluster?   Wed Sep 07, 2011 8:52 am

yeah mark gave me a whole cluster I guess ill have to try and check the fuses and contacts Ill let you know if I need anything Ill most likely be calling you soon to pick up that heater knob and ashtray if you have any left
Back to top Go down
No Moa

avatar

Posts : 3886
Join date : 2009-02-21
Age : 44
Location : Midcoast Maine

PostSubject: Re: Broken Gauge cluster?   Wed Sep 07, 2011 9:19 am

Yea I got some for ya, the tray is blue but should work with some SEM paint
Back to top Go down
http://www.collectorfbody.com
Sponsored content




PostSubject: Re: Broken Gauge cluster?   

Back to top Go down
 
Broken Gauge cluster?
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Finally Did The 9C1 Cluster Swap
» Gauge upgrade
» Z28 Cluster Gauge Overlay - $45
» Camaro gauge for caprice/impala mod
» Help needed for Tender Locomotive 5" gauge Kit - Stolen Boiler

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: