BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log inLog in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there is 0 user online :: 0 Registered, 0 Hidden and 0 Guests :: 1 Bot

None

Most users ever online was 101 on Fri Nov 27, 2015 1:40 pm
Latest topics
» WTB OBD1 Hypertech for 94 Roadmaster and 9c1 center caps
Thu Jan 19, 2017 4:41 pm by CrashMaster

» Looking for a fender and hood 96 Caprice
Wed Jan 18, 2017 12:59 pm by Black93Caprice

» Badass Cruise 2017
Tue Jan 17, 2017 5:51 am by bowtiepimp

» Looking for GMC caps
Sun Jan 15, 2017 8:31 pm by silverfox103

» WOnder why there is no picture?
Sun Jan 01, 2017 1:51 pm by 802

» 93 Roadmaster sedan on Craig's List
Fri Dec 30, 2016 11:18 pm by Matt Trakker

» 93 Roadmaster on Craig's List
Wed Dec 28, 2016 6:43 pm by silverton34c

» 39K RMW ?
Wed Dec 28, 2016 3:16 pm by Matt Trakker

» I wasn't even looking for this one, I swear!
Thu Dec 15, 2016 2:59 pm by No Moa

Search
 
 

Display results as :
 
Rechercher Advanced Search
January 2017
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
3031     
CalendarCalendar

Share | 
 

 Broken Gauge cluster?

View previous topic View next topic Go down 
AuthorMessage
JW94SSLT1



Posts : 20
Join date : 2011-02-27
Age : 32
Location : Windham, ME

PostSubject: Broken Gauge cluster?   Wed Sep 07, 2011 7:23 am

I'm not sure what to do my speed and gas gauge work but nothing else Ive changed the cluster out once and nothing changed I have no engine temp it always reads cold and oil pressure reads nothing and the volts is high all the time any ideas should i just change to a z cluster?
Back to top Go down
No Moa



Posts : 3874
Join date : 2009-02-21
Age : 44
Location : Midcoast Maine

PostSubject: Re: Broken Gauge cluster?   Wed Sep 07, 2011 8:42 am

Did you change the WHOLE cluster? or just the speedo piece?

I'd look at fuses first, then remove the whole assembly and clean the contacts. Maybe they are corroded a litte, i know mine in the 96 where.

Let me know what you need, i have a couple cars left with clusters. Come up and take a couple to try if you want.

Glen
Back to top Go down
http://www.collectorfbody.com
JW94SSLT1



Posts : 20
Join date : 2011-02-27
Age : 32
Location : Windham, ME

PostSubject: Broken Gauge cluster?   Wed Sep 07, 2011 8:52 am

yeah mark gave me a whole cluster I guess ill have to try and check the fuses and contacts Ill let you know if I need anything Ill most likely be calling you soon to pick up that heater knob and ashtray if you have any left
Back to top Go down
No Moa



Posts : 3874
Join date : 2009-02-21
Age : 44
Location : Midcoast Maine

PostSubject: Re: Broken Gauge cluster?   Wed Sep 07, 2011 9:19 am

Yea I got some for ya, the tray is blue but should work with some SEM paint
Back to top Go down
http://www.collectorfbody.com
Sponsored content




PostSubject: Re: Broken Gauge cluster?   Today at 9:36 am

Back to top Go down
 
Broken Gauge cluster?
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Finally Did The 9C1 Cluster Swap
» Gauge upgrade
» Z28 Cluster Gauge Overlay - $45
» Camaro gauge for caprice/impala mod
» Help needed for Tender Locomotive 5" gauge Kit - Stolen Boiler

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: