BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there is 1 user online :: 0 Registered, 0 Hidden and 1 Guest

None

Most users ever online was 132 on Wed Oct 04, 2017 3:26 pm
Latest topics
» In search of a 1996 knock module URGENT
Fri May 11, 2018 3:31 pm by fatvet

» Allagash Wilderness Waterway Canoe Trip 2018
Wed May 02, 2018 8:24 am by boojum

» Collected RMW stuff for 22 years--time for it to go!
Tue May 01, 2018 10:05 am by silverfox103

» HEY HOW AH YAH?
Wed Apr 25, 2018 4:28 pm by fatvet

» Looking for 91-96 RMW for sale
Mon Apr 23, 2018 12:21 pm by Wawa

» WTB: caprice taillights
Fri Apr 20, 2018 3:36 pm by fatvet

» Transmission temp sensor help..
Sun Mar 11, 2018 2:41 pm by Ironfistdog

» WTB: 235/70/R15 tires
Mon Jan 15, 2018 8:42 pm by demilo

» Triumph C 7000 Lift
Mon Jan 08, 2018 1:56 am by demilo

Search
 
 

Display results as :
 
Rechercher Advanced Search
May 2018
MonTueWedThuFriSatSun
 123456
78910111213
14151617181920
21222324252627
28293031   
CalendarCalendar

Share | 
 

 Broken Gauge Cluster

Go down 
AuthorMessage
JW94SSLT1

avatar

Posts : 20
Join date : 2011-02-27
Age : 34
Location : Windham, ME

PostSubject: Broken Gauge Cluster   Sun Mar 06, 2011 11:49 am

My digital display is not working I swapped it out with an other one but it still wont work any ideas on what might be wrong with it ?
Back to top Go down
toomanytoyz
Club President
avatar

Posts : 6878
Join date : 2009-01-20
Age : 41
Location : East Hampstead, NH USA

PostSubject: Re: Broken Gauge Cluster   Sun Mar 06, 2011 1:37 pm

You probably just need to re-flow the solder on the back of the circuit board.

http://www.impalassforum.com/vBulletin/showthread.php?t=244052

_________________
Bill "The Verb" Crovo - Resident Car Slut & Unicorn Hunter

A Toasted Marshmallow, A Long German, A Lame Suburban and expensive dreams...
Missing all my previous B's, D's and V... Sad
American Ricer
www.badassofne.net
"Ooooh! Look! Something shiny!"
NO MORE UNICORNS!!!!!

LOWER IT!!! Wink
Back to top Go down
http://impalass.uniquekind.net/
JW94SSLT1

avatar

Posts : 20
Join date : 2011-02-27
Age : 34
Location : Windham, ME

PostSubject: Broken Gauge Cluster   Sun Mar 06, 2011 1:50 pm

Thanks ill try that out
Back to top Go down
M.ROSS

avatar

Posts : 443
Join date : 2009-01-21
Age : 58
Location : So.Portland/ME

PostSubject: Re: Broken Gauge Cluster   Sun Mar 06, 2011 2:37 pm

I've got some spare clusters kicking around if you need parts.
I actually work in Windham/Club 302.
Let me know if i can help.
Back to top Go down
Ironfistdog

avatar

Posts : 2133
Join date : 2011-01-11
Age : 36
Location : Warren, MA

PostSubject: Re: Broken Gauge Cluster   Sun Mar 06, 2011 3:40 pm

This is probably gonna sound remedial but did you check the fuses and the wiring for any shorts/blown fuses? If you had a bad gauge and replaced it and its still not working, I would assume its probably a wiring problem. Also what kind of gauge did you replace it with, someone once said that a 9c gauge wouldn't work with a civi car because of the blackout option or something, idk as I never owned a 9c1. I'd pull every fuse just to look, also check the relays. Maybe just a pinched wire in the harness left connector B2 is the ign feed (pink wire) the ground is B3 (black) on the right connector the ign feed is located @ A5 (brown wire) and the ground is A6 (black and white) and also B4 (black). I'd start there!
Back to top Go down
JW94SSLT1

avatar

Posts : 20
Join date : 2011-02-27
Age : 34
Location : Windham, ME

PostSubject: Broken Gauge Cluster   Sun Mar 06, 2011 3:50 pm

I looked real quick at the fuses but didn't take each one out and look at it but I'm going to just to be sure
Back to top Go down
Ironfistdog

avatar

Posts : 2133
Join date : 2011-01-11
Age : 36
Location : Warren, MA

PostSubject: Re: Broken Gauge Cluster   Sun Mar 06, 2011 3:55 pm

If its just the digital display out and all the guges work and idiot lights are ok then check the right side harness B2 its a yellow wire that's the one for the digital display.
Back to top Go down
JW94SSLT1

avatar

Posts : 20
Join date : 2011-02-27
Age : 34
Location : Windham, ME

PostSubject: Broken Gauge Cluster   Sun Mar 06, 2011 4:52 pm

yeah everything works its just the digital display so ill have to check out that yellow wire thanks for your help!!
Back to top Go down
Sponsored content




PostSubject: Re: Broken Gauge Cluster   

Back to top Go down
 
Broken Gauge Cluster
Back to top 
Page 1 of 1
 Similar topics
-
» Finally Did The 9C1 Cluster Swap
» Gauge upgrade
» Z28 Cluster Gauge Overlay - $45
» Camaro gauge for caprice/impala mod
» Help needed for Tender Locomotive 5" gauge Kit - Stolen Boiler

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: