BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there are 3 users online :: 0 Registered, 0 Hidden and 3 Guests

None

Most users ever online was 126 on Fri Jun 02, 2017 5:36 pm
Latest topics
» 2017 10th Annual Roundup, List of Attendees
Wed Sep 20, 2017 5:54 pm by booth9C1SS

» Frame
Tue Sep 12, 2017 7:58 pm by MASShole9C1

» Midnight tour of the Allagash Ice Caves July 3rd!
Sun Sep 10, 2017 3:54 pm by MASShole9C1

» 2017 Tenth Annual B & D Roundup!! Mark your calendar! October 14h
Tue Sep 05, 2017 8:09 pm by silverfox103

» Forum Issues
Tue Sep 05, 2017 9:37 am by Matt Trakker

» Buick rear seat wanted FOUND
Tue Aug 15, 2017 6:04 pm by silverfox103

» The Official 1987 Two Door Body Off RE-build Thread!
Sun Aug 13, 2017 9:35 pm by MASShole9C1

» Rear tail light panel wanted
Sun Aug 13, 2017 3:19 pm by MASShole9C1

» 2017 Kancamagus Ride
Mon Jun 12, 2017 2:48 pm by Matt Trakker

Search
 
 

Display results as :
 
Rechercher Advanced Search
September 2017
MonTueWedThuFriSatSun
    123
45678910
11121314151617
18192021222324
252627282930 
CalendarCalendar

Share | 
 

 My cooling system problems

View previous topic View next topic Go down 
AuthorMessage
hooptycaprice

avatar

Posts : 49
Join date : 2009-03-09
Age : 40
Location : Johnston RI

PostSubject: My cooling system problems   Thu May 06, 2010 6:31 pm

When I first got my Roadie, I needed a new rad because of the previous owner tightened the top hose to the point of breaking the plastic tank. So I replaced the rad and put a new thermo for good measure (WP was new)

Now when I drive the car, it bearly gets warm (about one line above cold) . When sitting in traffic, it will go to alittle over the middle (common for LT1 ive read) then the fan kicks on and lowers it to alittle before halfway. A/C cranks ice cold and secondary fan works properly.

I also have no heat. Not even a little warm. No matter where the temp gauge is it blows cold, to the point that raising the temp on the climate control when the A/C is on does nothing. (90 degrees to 60 is is pretty much the same) Also, when I got the car, the black plug to the A/C canister was unplugged?

Where should I start? I beleve it could be a number of things, but would like to know what to start checking in order.

Thanx
Back to top Go down
bammax

avatar

Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: My cooling system problems   Thu May 06, 2010 7:11 pm

Sounds like the system is working too well. The fans shouldn't be kicking on so early. They usually won't come on until the car gets very toasty. I'd say that the fans are the culprit. Maybe the temp sensor is giving a bad reading and making the fans kick on too early.

By the way if the heater core gets plugged then you lose the heat. It's very common on b-bodies. They really need to be thoroughly flushed on a daily basis Wink
Back to top Go down
 
My cooling system problems
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Strange overheating issue...
» What is the Inherent Problems with Shadow Warriors?
» Craigtone's System
» problems with caseroles
» Blue's Bank event system

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: