BADASS of New England

An automobile club for the enthusiast who enjoys the last of the big GM cars. The rear wheel drive B and D bodys. Chevrolet Impala SS, Caprice, 9C1, Buick Roadmaster, Oldsmobile Custom Cruiser, Cadillac Fleetwood
 
HomeHome  RegisterRegister  Log inLog in  
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Who is online?
In total there are 3 users online :: 0 Registered, 0 Hidden and 3 Guests :: 1 Bot

None

Most users ever online was 101 on Fri Nov 27, 2015 1:40 pm
Latest topics
» 2012 and up Caprice PPV
Sat Dec 03, 2016 4:36 pm by No Moa

» I wasn't even looking for this one, I swear!
Thu Dec 01, 2016 9:52 am by 95brmw

» This forum needs a pulse check.... pics included
Tue Nov 29, 2016 1:04 pm by Grumpy

» 1994 Roadmaster Estate Wagon
Tue Nov 29, 2016 10:15 am by lvd2340

» Who're You callin a Turkey?
Thu Nov 24, 2016 1:32 pm by 802

» New Ride
Thu Nov 17, 2016 8:17 am by silverfox103

» Complete SS interior.
Thu Oct 27, 2016 1:35 pm by No Moa

» 2016 9th Annual Roundup, List of Attendees
Tue Oct 18, 2016 1:04 am by MASShole9C1

» Pictures from the 2016 Roundup
Mon Oct 17, 2016 8:03 pm by toomanytoyz

Search
 
 

Display results as :
 
Rechercher Advanced Search
December 2016
MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
262728293031 
CalendarCalendar

Share | 
 

 95 RMW Trouble Starting/Stumbles Running Rich

View previous topic View next topic Go down 
AuthorMessage
justinlamb82



Posts : 85
Join date : 2010-03-25
Age : 34
Location : Berlin MA

PostSubject: 95 RMW Trouble Starting/Stumbles Running Rich   Thu Mar 25, 2010 4:11 pm

Ok I'm getting a little aggrevated. Have a 1995 Buick Roadmaster Wagon. I have just recently Replace the OPTI and Coil with a set from Accel, New fuel pump and sending unit and egr valve. Can't figure out why the car is having problems starting when it is cold, once it is warmed up it starts easier. I have to hold it to the floor board in order to get it started, if you tap the gas after it is running it falls on its face until it up to running temp. Also if you rev it up it is letting out black exhaust and what i believe is to be unburned fuel, you can smell it is running way to rich. HELP !!!!!!!!
Back to top Go down
mean ss



Posts : 648
Join date : 2009-02-25
Age : 58
Location : Nashua NH.

PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Thu Mar 25, 2010 4:15 pm

you might need a new ECT engine coolant temperature sensor
Back to top Go down
justinlamb82



Posts : 85
Join date : 2010-03-25
Age : 34
Location : Berlin MA

PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Thu Mar 25, 2010 11:25 pm

I did change that sensor and the throttle positioning sensor and still nothing has changed. Mad
Back to top Go down
Guest
Guest



PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Fri Mar 26, 2010 6:01 am

You said you replaced the sending unit? Did it come with a new pump, harness, sock. Did you replace the filter? What brand was the sending unit? AC Delco?

It is not good to change out several things at once. It make tracking issues down issues more difficult. Are you sure the opti is indexed correctly?
Back to top Go down
justinlamb82



Posts : 85
Join date : 2010-03-25
Age : 34
Location : Berlin MA

PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Fri Mar 26, 2010 7:19 am

Yes the sending unit is an AC Delco, brand new fuel pump, sock, harness, I did not replace the filter. Fuell pressure is not an issue as we have checked that and it is "running rich". What do you mean by it being Indexed propely? If you mean was it installed in the position as the one i took out than yes it is. I wish that my car would read on my scanner because it would probably make things easier to find.
Back to top Go down
mean ss



Posts : 648
Join date : 2009-02-25
Age : 58
Location : Nashua NH.

PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Fri Mar 26, 2010 10:22 am

it the CEL on ? have you changed the plugs and wires ?
so it runs great when its warm,have you changed the PCM at anytime.
when it warm it is in closed loop reading the O2's and adjusting the fuel trims.
it can smell rich when its running lean,what is the fuel pressure ? you want 43.5
with the vacuum line off the regulator.
find someone near you that has Datamaster then do a data log.
Back to top Go down
justinlamb82



Posts : 85
Join date : 2010-03-25
Age : 34
Location : Berlin MA

PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Fri Mar 26, 2010 11:13 am

The check engine light is not on, the plugs and wire are recent. Even when it is warm the engine does have a little enitian stutter but not at much of a stumble as if it was cold. I haven't changed the PCM at all. I will re check the fuel presseure and give you a number.
Back to top Go down
justinlamb82



Posts : 85
Join date : 2010-03-25
Age : 34
Location : Berlin MA

PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Fri Mar 26, 2010 9:29 pm

bounce I would like to thank MEAN SS, It was the temp sensor screwing the whole car up. There are two sensors and the auto parts store told me that the one they gave me was the one that ran to the ECM, but they were wrong. I changed the one on the water pump and the car runs AWESOME !!!!!!!!!!!!!! So if any one ever has the issue it's $13.27. THANK YOU THANK YOU THANK YOU !!!!!!!!! MEAN SS IS THE MAN !!!!!!!!!!!!!! bounce bounce bounce bounce bounce
Back to top Go down
mean ss



Posts : 648
Join date : 2009-02-25
Age : 58
Location : Nashua NH.

PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Fri Mar 26, 2010 9:34 pm

no problemo Cool


Bob
Back to top Go down
Guest
Guest



PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Fri Mar 26, 2010 9:41 pm

Good to here Bobby was able to help you out. The other sensor on the pass side of the head is the one for the guage.
Back to top Go down
justinlamb82



Posts : 85
Join date : 2010-03-25
Age : 34
Location : Berlin MA

PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Fri Mar 26, 2010 9:48 pm

again thank you, it's amazing that something so simple can screw up the entire engine, thanxs
Back to top Go down
bammax



Posts : 2301
Join date : 2009-02-22
Age : 35
Location : Mansfield, Ma

PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Sun Mar 28, 2010 1:10 pm

If in doubt assume it's a sensor. That's my experience with these cars.
Back to top Go down
Sponsored content




PostSubject: Re: 95 RMW Trouble Starting/Stumbles Running Rich   Today at 11:01 pm

Back to top Go down
 
95 RMW Trouble Starting/Stumbles Running Rich
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Lister D Starting and Running, the Cuts Out!
» spark plug
» Having trouble starting my pee wee .020 Help!!!
» Wolseley WD8 running problems.
» 94 caprice won't stay running

Permissions in this forum:You cannot reply to topics in this forum
BADASS of New England :: 91-96 B & D-body tech :: Problems / Maintenance-
Jump to: